2003 Ford Escape, possibly trany slipage - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-11-11, 04:03 PM Thread Starter
Registered User
 
Join Date: Mar 2011
Posts: 18
Exclamation 2003 Ford Escape, possibly trany slipage

just bought a 2003 Ford Escape V6 today. driving home i realized that the car dropped in RPMs and it sounded like the tranny wasnt catching to accelerate. sidenote: the car has not been driven much in a while up to this point, so im hoping that may the reason. there is also a low idle, close to stalling.

Id really appreciate the


-johnny

johnnyaljr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-11-11, 04:27 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 15,160
Re: 2003 Ford Escape, possibly trany slipage

First thing I would check would be ATF level and condition / colour . Also check engine oil and coolant levels .
R.S.LOGAN is offline  
post #3 of 3 (permalink) Old 03-12-11, 10:56 AM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2003 Ford Escape, possibly trany slipage

Commonly misdiagnosed as a transmission problem at some auto shops, is a bad or faulty TPS (throttle position sensor) along with (but not always) a bad IAC, or idle air controller. Both sensors are located on or around the throttle body and run $40 ea. Most last anywhere from 60-120K; or 4-10 years.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome