2006 Escape engine code P0707 - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-20-2012, 08:53   #1 (permalink)
Registered User
 
Join Date: Jul 2012
Posts: 1
2006 Escape engine code P0707

Hi,

I have a 2006 Escape three days ago when I was driving on highway the transmission kept changing from drive to 2nd to 1st. Did this for a couple of miles and then it was parked. That evening it drove fine. The next morning I started it and the engine code light was on but it drove fine and has been since. I went to auto place and had code read and it stated:

P0707- Transmission Range Sensor Circuit Low Input

What do I need to do and is this something I can fix myself or do I need to take it the shop.

Thanks for any assistance.
mx3_mom is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-20-2012, 15:01   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,549
Re: 2006 Escape engine code P0707

OBDII Code P0707 - Transmission Range Sensor Circuit Low Input | Engine-Codes.com

Sounds like the transmission range switch.

Ford escape: cylinder..the fuses and relays checked out..disconnected - JustAnswer

The lower diagram might bot be the same tranny as yours, but it should be in that general location. Someone correct me if I'm wrong, but if it's working fine now, you're more than likely loose rather than a faulty switch, since it's shifting normal now.
CatSkinner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:08.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.