2007 Escape Hybrid - engine dies at speed - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-01-2009, 13:09   #1 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 1
2007 Escape Hybrid - engine dies at speed

Uaually fails while operating in speed control after several miles (10-40) at 65-75 mph. also usually on an upgrade. Engine just stops. red triangle with exclaimation sign comes on and panel instructs me to pull over as safely and quickly as possible. First happened in July at the end of a 5000 mile trip. happened once a month through early December. Now occuring 3-5 times between Albuquerque and Socorro, NM (~70 miles). A dealer in Albuquerque got it to fail once, but the computer contained no information. Was in the shop for 4-5 weeks. (I think the dealer never drove it for any length of time or any distance at highway speeds). Once it has failed, it quickly starts up and operates fine until the next failure (though I keep slowing the average speed down). Have had it fail as low as 45 mph.
borealowl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-04-2009, 08:52   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 2007 Escape Hybrid - engine dies at speed

I'd take it to another dealer. Make sure to document as much information as you can on paper...and take that to the dealer as well. Be sure to leave it there for the day with a full tank of fuel so they can properly test it. I've taken vehicle in with 1/4 tank and they won't properly test it on the highway if it doesn't have fuel - cheapskates!
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:57.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.