2008 Escape - Strange speedometer/odometer behavior - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-10-2013, 19:14   #1 (permalink)
Registered User
 
Join Date: Sep 2013
Posts: 4
confused 2008 Escape - Strange speedometer/odometer behavior

I am brand new to this forum, so hello to all, and thanks in advance for any help.

I have a 2008 Escape XLS, manual, with 104k miles. Here is a timeline of recent occurrences:

9 months ago, the serpentine belt fell off. We put it right back on.

1 month ago, the serpentine belt fell off again. We didn't notice until it killed the battery. We had the battery and the tensioner pulley both replaced, and it was fine until a few days ago...

The check engine light came on, the speedometer dropped to 0, and the odometer turned to all dashes. After a while, they came back. The engine light has stayed on, but the vehicle seems to be running smoothly. The speedometer and odometer still intermittently fail. Each time, it lasts a few minutes before both return to normal.

Any advice? Could this be related to the serpentine belt/dead battery problem? I took it to Advance Auto Parts to have them read the code, but it was raining, and they said they "aren't allowed to take equipment outside in the rain."

Thanks!
lateralus8305 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-11-2013, 03:41   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,439
Re: 2008 Escape - Strange speedometer/odometer behavior

Possibly the vehicle speed sensor (VSS) or worth checking wiring .
R.S.LOGAN is offline   Reply With Quote
Old 09-11-2013, 05:07   #3 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,007
Re: 2008 Escape - Strange speedometer/odometer behavior

Would need to know what the code is to Start.


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 09-11-2013, 06:48   #4 (permalink)
Registered User
 
Join Date: Sep 2013
Posts: 4
Re: 2008 Escape - Strange speedometer/odometer behavior

Ok. Just had the codes read. 0500A and 1502P came back. The auto parts employee told me that the 0500A is the speed sensor, but he didn't know what 1502P means. Thanks!
lateralus8305 is offline   Reply With Quote
Old 09-11-2013, 19:54   #5 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,007
Re: 2008 Escape - Strange speedometer/odometer behavior

Ill try and remember to look into that one tomorrow. An ABS light on?


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 09-12-2013, 02:42   #6 (permalink)
Registered User
 
Join Date: Sep 2013
Posts: 4
Re: 2008 Escape - Strange speedometer/odometer behavior

No ABS light. Thank you!
lateralus8305 is offline   Reply With Quote
Old 09-12-2013, 17:51   #7 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,007
Re: 2008 Escape - Strange speedometer/odometer behavior

I forgot to look today but need to ask. What motor and Trans do you have?


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 09-12-2013, 19:08   #8 (permalink)
Registered User
 
Join Date: Sep 2013
Posts: 4
Re: 2008 Escape - Strange speedometer/odometer behavior

It is an XLS model, 4 cylinder, 5 speed manual transmission
lateralus8305 is offline   Reply With Quote
Old 09-15-2013, 18:20   #9 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,675
Re: 2008 Escape - Strange speedometer/odometer behavior

As RS had suspected, both codes reflect back to the speed sensor.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 09-16-2013, 08:50   #10 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,007
Re: 2008 Escape - Strange speedometer/odometer behavior

The p1502 is vss intermittent. The escape with 5 speed does use a vss. It's located on back side of the Trans. I would suspect it is failing. Because its intermittent its going to be hard to verify unless you can acces the sensor while its acting up.


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:17.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.