'6 Escape Right Blinker Not Working After Towing - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-17-09, 08:44 AM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 2
'6 Escape Right Blinker Not Working After Towing

I have an '06 Escape AWD with a self installed tow package. The wiring kit is the $45 from etrailer.com. Shortly after installation, my right blinker was working intermittently. ie It would blink fast on the dash panel, but the actually blinker light itself was not blinking. I reconnected/tightened the connections and it was working fine for a few weeks.

Yesterday I was towing a trailer and the blinker worked fine on the way down, but on the way back, the dash light and the blinker lights were not working. I tried disconnecting the trailer wires and the wiring module but it did not help. After much googling I found an old forum post which someone had the same problem, unplugged their battery for 10 mins and it was fixed. I am going to try that, but if it doesn't work is there a flasher module located somewhere that can be replaced? The owner's manual wasn't very helpful. Thanks.


Last edited by bendog2784; 05-17-09 at 08:52 AM. Reason: Added detail to title.
bendog2784 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-17-09, 09:57 AM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 2
Re: '6 Escape Right Blinker Not Working After Towing

I did the 'battery trick' and the lights seem to be working... for now.
bendog2784 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome