Brakes......oy lol - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-20-07, 07:10 PM Thread Starter
Registered User
Join Date: Jan 2007
Posts: 2
confused Brakes......oy lol

Hey everybody. Just signed up for this looks pretty cool!! I have an 01 xlt 4x4 with 83,000. Second owner got it with 61,000 in August. Yeah I do a little driving LOL. I just put brake fluid about 2 weeks ago as the brake light was illuminated on my dash after I released the ebrake. Thought everything was taking care on Thursday (this is Saturday night I'm writing this) the ABS light came on driving to work. Friday the light was out but the brakes feel.....bubbly? It's happening still today. The only time it seems to not be "bubbly" is when you almost fully apply the brakes. I am hoping this is not a high cost repair as where I just had the brakes done in October I think it was to the tune of $600. Any suggestions? Be greatly appreciated!

timinmass is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome