Coolant light comes on but temp. gauge is fine. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-08-2006, 03:42   #1 (permalink)
Unregistered
Guest
 
Posts: n/a
Coolant light comes on but temp. gauge is fine.

I have a 2001 Ford Escape with a v6 and the coolant light keeps coming on. The temperature gauge stays in the middle. Any suggestions?
  Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2006, 04:10   #2 (permalink)
Registered User
 
Join Date: Apr 2006
Posts: 3
Re: Coolant light comes on but temp. gauge is fine.

Hi there,
I had the same problem, you need to top up the coolant in the reserve plastic tank, it has a sensor in it when coolant is low, light goes off straight away!
4x4 4Ever is offline   Reply With Quote
Old 10-14-2008, 18:27   #3 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 1
Re: Coolant light comes on but temp. gauge is fine.

I have the same problem, and my mechanic told me that the sensor can go bad and the entire coolant reservoir needs replaced. Is this true? The level in my reservoir is where it is supposed to be, and the light comes and goes intermittingly.
dfersch is offline   Reply With Quote
Old 11-13-2008, 09:59   #4 (permalink)
Registered User
 
Join Date: Nov 2008
Posts: 1
Re: Coolant light comes on but temp. gauge is fine.

I have the same problem on my 2001. It started about 2 years ago. I just don't pay attention to it. I soon figured out it was a bad sensor.

Jim Rooney
jimrooney is offline   Reply With Quote
Old 01-15-2009, 19:45   #5 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 1
Re: Coolant light comes on but temp. gauge is fine.

Our 2001 Escape does the same thing. I believe the sensor in the coolant tank needs replaced, but I see no sense in spending the money to replace it. I just check the coolant level once every other month to make sure.
bobbluebird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:32.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.