EGR Sensor Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-18-12, 11:21 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 2
confused EGR Sensor Problem

Hi

This is the first time Im using this forum. My brother in law recommended this to me for a good source to ask question regarding my Ford Escape. I have a check maintence light going off on my vehicle. I took it to get the car smog and the problem was the P0403 Code (EGR Sensor). I expected the engine and notice that the electrical plug to the sensor was damaged. I purchased a new EGR sensor and plug and installed it to the vehicle. I start the car up and the check engine light disappeared. After 30 minutes of driving the light reappeared. Im not sure what else to do. Someone please help.

bingapher is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-19-12, 07:12 AM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: EGR Sensor Problem

When replacing any sensor, be sure to disconnect the battery for at least 15min. This will allow the computer to relearn the sensor properly. Otherwise, more knowledgeable EGR guys will chime in soon!

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
post #3 of 3 (permalink) Old 02-19-12, 10:11 AM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 2
Re: EGR Sensor Problem

Before I replace the parts on my car, I disconnected the battery. It took me 30 minutes to install the parts.
bingapher is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome