Electrical problems? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-29-11, 02:54 PM Thread Starter
Registered User
 
Join Date: Aug 2011
Posts: 5
Exclamation Electrical problems?

I have 2006 ford escape 4 cylinder. I have noticed recently when i am stopped a light i can see my headlights constantly dimming from normal to low and also the back light in my display where the odometer is located. My battery light indicating green which should be for good, and it has not stalled at all. I have also been having a problem with a rough idle which i have posted about already.

I have pulled the throttle body (which it was nasty) and cleaned it but i was unable to get the IAC off. It seems to be working as i can see it adjusting the RPM when the A/c compressor kicks on and off. I do oil changes frequently , have a K&N filter , and replaced the fuel filter. I am only at 51,000 miles and should not be having all these issues

I asked Ford to look at it but they wanted $150 just to check it out, and i'm like go to hell. I just wish someone had an answer i am getting so sick of this truck
NGEL is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-29-11, 03:13 PM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 13,910
Re: Electrical problems?

Check alternator output / charging rate .
R.S.LOGAN is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome