Front Wiper Motor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2013, 07:40   #1 (permalink)
Registered User
 
Join Date: Nov 2012
Posts: 6
Front Wiper Motor

2005 Merc Mariner, front wipers over the last couple months have been really slow... They now finally quit working. I checked the fuse; good. I pulled the motor and it worked not hooked up to the linkage. I just assumed it was just weak and I didn't have my test meter with me. Well put a new motor in and it's the same thing, doesn't work. The linkage moves freely when not hooked up, both ends of the plug looks good; but I cleaned it anyway.

Where to next? Any help is much appreciated.
Musgle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-27-2013, 12:25   #2 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 3,239
Re: Front Wiper Motor

Sounds like the switch might be going.
__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Old 02-27-2013, 12:35   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 9,175
Re: Front Wiper Motor

Dont know if this would have an effect ,

Body, Interior & Misc., November 22, 2005
Ford recalls 2006 E150, E250, E350 Escape, Expedition, F150, Ranger, Taurus, Lincoln Navigator, Mercury Mariner, and Mercury Mountaineer due to a possible lack of lubricant on the wiper motor output shaft gear. Eventually, loss of wiper function will result. Dealers will grease the wiper motor gears as necessary.
R.S.LOGAN is offline   Reply With Quote
Old 02-27-2013, 18:39   #4 (permalink)
Registered User
 
Join Date: Nov 2012
Posts: 6
Re: Front Wiper Motor

Dang, didn't think of the switch. I'll have to test it.

Thanks for the bulletin, too.
Musgle is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:14.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.