horn not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-19-07, 03:38 PM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 1
horn not working

I have a 2001 Escape and the horn does not work. There is a clicking sound when I push the horn. I checked the fuse and it is fine. Is there another thing I can do on my own to fix this so I don't have to pay hundreds of dollars?

annachris is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-19-07, 05:56 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: horn not working

Find the horn under the hood and see if you have power going to it. (while someone hits the horn button) If you have power to it, just replace the horn/ horns. No power, check the relay, that is probably the clicking noise and probably what is bad.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome