My Escape is sputtering / losing power. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-08-2013, 18:22   #1 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 5
My Escape is sputtering / losing power.

Hello all,

I have a 2009 Ford Escape V6. Last week, it lost power and started to sputter. The wrench light came on. I was low on gas so I thought this was the problem. After I filled it, it repeated this one more time and then it did not happen again. A friend tried to pull the codes but he said there was NO codes.

I did clean the throttle body that day, it was grimey so I thought it may be stuck.

One more - the idle gets a little weird every now and then since this has happened. Revs up and then down.

Come to today, I was driving to the store and it did the exact same thing as above but not only did the wrench light come on but the service engine light. I turn the car off and it runs fine for a block and then the above repeats itself.

I was going to order a throttle body but I was hoping there may be more suggestions. Thanks so much.

Thank you in advance,
Sputter put put sputter
Escape2009 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-08-2013, 21:12   #2 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 772
Re: My Escape is sputtering / losing power.

Well have done a lot of throttle bodies but first I would check air filter fit and look into the MAF. If dirt gets inside can play hell with driveability


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 07-08-2013, 21:13   #3 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: My Escape is sputtering / losing power.

There has to be a code or more. Autozone or O'Riely's will check for free.
__________________
Bert
Bert is offline   Reply With Quote
Old 07-08-2013, 21:26   #4 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 772
Re: My Escape is sputtering / losing power.

A wrench light does not always set a code. If his check engine light is on as he says than yes code should be present. Wrench lamp is usually a non emissions failure not always acompanied by a DTC


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 07-09-2013, 09:06   #5 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 5
Re: My Escape is sputtering / losing power.

Thanks for the replies everyone. I ordered some maintenance parts (spark plugs, air filter) last night. Today I came across this and I called my dealership:

Ford Escape throttle body defects may trigger NHTSA investigation - National Ford | Examiner.com

I called the dealership and they said my issue sounds very much like a throttle body failure. The actual part is on back order due to this issue. Luckily they were nice enough to put one on order for me over the phone.

My husband is bringing a code reader by today after work - I can't drive it to Auto Zone at the moment... He did say that while he and a friend did some maintenance on it last year, it did throw a throttle body code but they cleaned it up and figured that was the end of that.

Good thing I can telecommute to work :)
Escape2009 is offline   Reply With Quote
Old 07-09-2013, 17:08   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: My Escape is sputtering / losing power.

Glad to hear you might have it on amends. Keep us posted.
__________________
Bert
Bert is offline   Reply With Quote
Old 07-14-2013, 09:19   #7 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 5
Re: My Escape is sputtering / losing power.

Thank you, Bert. That did it. Replaced it this morning and took it for spin. The guy at Ford said there are 8000 on back order.
Escape2009 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:06.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.