New here, dash light question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-27-2009, 06:06   #1 (permalink)
Registered User
 
G Holl's Avatar
 
Join Date: Feb 2009
Location: Mogadore, Ohio
Age: 50
Posts: 3
New here, dash light question

2005 Escape 4x4, the ABS light is on and the 4WD lights blinks every few minutes. Any ideas.

Thanks
G Holl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-28-2009, 13:31   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,474
Re: New here, dash light question

You'd have to get the engine codes scanned to find out what the problem is exactly. I would say that it's probably a faulty ABS sensor, which may be trying to engage the 4wd system at times as the computer might sense a false loss of traction and not know what to do.
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Old 03-02-2009, 03:44   #3 (permalink)
Registered User
 
G Holl's Avatar
 
Join Date: Feb 2009
Location: Mogadore, Ohio
Age: 50
Posts: 3
Re: New here, dash light question

Quote:
Originally Posted by 360ci View Post
You'd have to get the engine codes scanned to find out what the problem is exactly. I would say that it's probably a faulty ABS sensor, which may be trying to engage the 4wd system at times as the computer might sense a false loss of traction and not know what to do.
Ok thanks, I was also told it could be a dirty sensor. Guess I will find out for the first time how good the extended warranty is.
G Holl is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.