Please Help. Loose Coil On Plug, Car keeps cutting off - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Escape | C-MAX | Mercury Mariner Forum This forum is for discussion of the Ford Escape, C-MAX, the Ford Escape Hybrid and the Mercury Mariner.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2011, 13:52   #1 (permalink)
Registered User
 
Join Date: Oct 2011
Posts: 1
Please Help. Loose Coil On Plug, Car keeps cutting off

Hi guys.

I will put it out there right now that I know diddly squat about cars. So here it goes.

My used 2001 Ford Escape has been having problems lately where it sounds like its misfiring, and the last few weeks it goes through moments where I start it, and it will cut right off. Now, as I drive it, it cuts off evertime I come to a stop. Its real weired because the RPM's go all the way down to 0 when it is idle, then it will sputter out and cut off.

I opened it up and I noticed something weird when I looked at the COP's. One of the bolts was different, and I could jiggle the COP and even pull it all the way out with very little effort. The bolt (or screw) that is in there seems to be too small. I dont know why its like that, my guess is when someone changed the spark plugs, they didnt put the right screw in there.

My question is, do you think this will fix my problem. Is there something else you think needs to be done?

Thanks in advance
bornnraisedno is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2011, 20:17   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: Please Help. Loose Coil On Plug, Car keeps cutting off

I doubt that's the problem. Take it to Autozone and they'll pull codes for free. The light doesn't have to be on.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-19-2011, 02:59   #3 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,853
Re: Please Help. Loose Coil On Plug, Car keeps cutting off

Try cleaning idle air control valve and check engine coolant temp sensor .
R.S.LOGAN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Escape | C-MAX | Mercury Mariner Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.