00 Navigator - 3 Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-26-11, 08:37 PM Thread Starter
Registered User
Join Date: Apr 2011
Posts: 3
00 Navigator - 3 Problems

1st - When I use my keyfob or the door lock buttons to unlock/lock the doors, the locks don't all unlock, or they pop up or down halfway but not engaging enough to lock or unlock on their own, any idea?

2 - Sometimes when I accelerate from a stop, the truck will go, then feel like your foot slipped off the accelerator, and then go again. But sometimes it will actually stall out and as mentioned, it only does this sometimes. Took it in, they had the truck for 4 days and they replaced a cam position sensor, some other sensor and a bad engine ground. They also cleaned the MAF but determined if that work didn't fix it, either I need a new MAF or new plugs, but the plugs only have 67,000 miles. Still have this problem at the present time.

3rd - I bought a new oil sending unit as I have been getting some weird readings from my oil pressure gauge as usually when I start up, it shows no pressure, then will come on a few seconds or minutes later and will occasionally do this will driving. I would like a more accurate reading as well since my vehicle is burning oil (bad rings) so my question is can I buy an autometer gauge to read actual psi and would that reflect any difference when oil is getting low?
naviracer23 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome