01 Brake Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-25-09, 09:14 PM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 2
01 Brake Problem

Howdy all!

I'm replacing the rotors and pads on my dad's 01 Expedition. I got the EBC 7000 Green Severe Duty Pads and Wagner Rotors.
The problem I'm running into is that I cannot get the flippin' caliper back on. The caliper's pistons are completely depressed. It should slide right on, but it won't. I've even broken the piston boots. Which means I'll need to buy a rebuilt caliper.

Should I have the rotor turned slightly or what? I'm at a loss right now....

Thanks

tulsapete is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-26-09, 10:50 AM Thread Starter
Registered User
 
Join Date: Mar 2009
Posts: 2
Re: 01 Brake Problem

Well, I figured it out using an unorthodox method of putting the caliper on.

I assemble the caliper, pads and caliper bracket and then slide the entire assembly on to the rotor.

Hopefully this can help somebody in the future with a similar problem.
tulsapete is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome