01 Navigator - Engine Temp - Water Sound??? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-20-2010, 23:09   #1 (permalink)
Registered User
 
Join Date: Mar 2009
Posts: 16
01 Navigator - Engine Temp - Water Sound???

2001 NAV - enging temp always runs about 25% up on the guage (seems a little low) - heater works okay, but not as hot as it used to be. Now I am noticing a "swishy" water sound behind the dash (sound like water running through a pipe). Mainly notice this at first startup in the morning (when cold) or if it is at idle for a while. Any ideas what might be going on? Thanks for the advice?
jayrob1989 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2010, 07:59   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,757
Re: 01 Navigator - Engine Temp - Water Sound???

If ti's not heating up to normal operating temperature, the heater won't be as warm as it should be. Is the coolant as full as it should be? Some times an air pocket will cause that noise too.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-22-2010, 20:55   #3 (permalink)
Registered User
 
Join Date: Mar 2009
Posts: 16
Re: 01 Navigator - Engine Temp - Water Sound???

I will check the level tomorrow - where should the temp guage read under normal operating conditions?
jayrob1989 is offline   Reply With Quote
Old 02-22-2010, 21:10   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,757
Re: 01 Navigator - Engine Temp - Water Sound???

It should be in the center. It really depends on the actual temerature of the coolant. Sometimes the gauges can be off. In most cases, the gauge does read correct.
__________________
Bert
Bert is offline   Reply With Quote
Old 02-23-2010, 09:11   #5 (permalink)
Registered User
 
Join Date: Mar 2009
Posts: 16
Re: 01 Navigator - Engine Temp - Water Sound???

Fluid level looks normal - definitely not close to half way on the temp guage. What steps should I take at this point? New Thermostat? Flush the cooling system? Thanks ----
jayrob1989 is offline   Reply With Quote
Old 02-23-2010, 11:05   #6 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,757
Re: 01 Navigator - Engine Temp - Water Sound???

That would be a good start. The coolant becomes acidy and starts to corrode the system if it isn't replace periodicaly. I don't know if yours has the long life coolant but it's supposed to be rel=placed after 5 years. The green coolant is annualy.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:04.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.