03 expedition check engine light - engine coolant temperature low - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-03-2008, 14:21   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 3
03 expedition check engine light - engine coolant temperature low

I got a check engine light a few days ago and had it put on the code reader. I forgot to write down the code but it said "engine coolant temperature low." I thought it might be a stuck open thermostat so I pulled it and looked at it. Looks good, so I buttoned it back up.

The coolant level was good (and I refilled what I spilled when taking the thermostat out)... Now what? Bad sensor? Something else? I really want to fix this myself since I doubt its anything more than a minor problem.

I appreciate any help. I searched for a while before posting but didn't find a similar thread. TIA.

Lastly, I DID find an answer to a rear A/C problem from another thread. Thanks to those that have posted about the stripped gears causing the clicking sound in the rear A/C. I've been trying to figure that one out for a while too!
wn27 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-03-2008, 22:08   #2 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 3
Re: 03 expedition check engine light - engine coolant temperature low

Anyone?
wn27 is offline   Reply With Quote
Old 12-07-2008, 11:56   #3 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 3
Re: 03 expedition check engine light - engine coolant temperature low

One more bump. Bueller?
wn27 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.