03 Nav Windshield Washers Not Working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-04-12, 10:11 PM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 3
03 Nav Windshield Washers Not Working

My windshield washer stopped working. I checked the fuses and they were good. I don't hear the washer motor when the pump is activated. The wipers come on, but no washer fluid is sprayed out. Does anyone have any procedures for troubleshooting this particular problem?

Thanks,
P1000

proton1000 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-05-12, 04:03 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,902
Re: 03 Nav Windshield Washers Not Working

Check you're getting power to washer pump .If so , and not operating , knackered pump.
R.S.LOGAN is offline  
post #3 of 3 (permalink) Old 02-05-12, 09:15 AM
Registered User
 
Join Date: Apr 2010
Posts: 14
Re: 03 Nav Windshield Washers Not Working

If the pump is working check the hoses for any breaks they can become brittle from the washer fluid. If there are no broken hoses and the pump is working properly a plugged hose can be the issue also. Compressed air can blow that stuff right out.
plyr503 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome