03' Navigator: Front End Noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-17-11, 02:31 AM Thread Starter
Registered User
 
Join Date: Jan 2010
Posts: 3
03' Navigator: Front End Noise

I am experiencing some rattle noise coming from the driver side of the front end whenever I drive over a bump in the road. I have new tires. I have about 85,000 miles on the vehicle. Are there any front end components that are known for needing replacement at this mileage?

Any ideas would be great.

Thanks,
Proton1000

proton1000 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-19-11, 12:57 PM
Martin J
 
Join Date: Apr 2010
Location: Abu Dhabi, UAE
Age: 45
Posts: 6
Re: 03' Navigator: Front End Noise

I had something similar on a 2000 navigator. every time i accelerated hard or went over a bump, nasty knocking sound. We replaced all 4 tyres and the sway bar bushes which were disintegrated. noise have never returned. Am looking to replace all of the minor steering componenets (ball ties, pitman arm etc), there are kits on ebay for less than $140
mvmarica is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome