03 navigator limited/no heat - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-23-13, 10:20 AM Thread Starter
Registered User
 
Join Date: Aug 2013
Posts: 24
03 navigator limited/no heat

My navigator has a heater issue. The rear works fine but the front only works for about a minute or so and then goes cold so lately I've been just running rear heat to keep warm. Hasn't gotten really cold yet.. What should I do?

Texas_finest1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-23-13, 10:48 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,806
Re: 03 navigator limited/no heat

Check this , should help you ,

http://www.justanswer.com/ford-linco...-cold-air.html
R.S.LOGAN is offline  
post #3 of 4 (permalink) Old 10-28-13, 09:44 PM Thread Starter
Registered User
 
Join Date: Aug 2013
Posts: 24
Re: 03 navigator limited/no heat

I'm now thing it may be heater control valve.. How does it work? Engine side of hose is warm but the heater core side is cool... When I start the truck vacuum sucks and engages the valve and when the engine is off it releases. Is this proper operation?
Texas_finest1 is offline  
post #4 of 4 (permalink) Old 10-29-13, 02:19 PM Thread Starter
Registered User
 
Join Date: Aug 2013
Posts: 24
Re: 03 navigator limited/no heat

I HAVE HEAT. I took off the vacuum line on the heater control valve, plugged it and now the heat is working. I don't know how it works but not worried about it now.
Texas_finest1 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome