03 navigator limited/no heat - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-23-2013, 10:20   #1 (permalink)
Registered User
 
Join Date: Aug 2013
Posts: 24
03 navigator limited/no heat

My navigator has a heater issue. The rear works fine but the front only works for about a minute or so and then goes cold so lately I've been just running rear heat to keep warm. Hasn't gotten really cold yet.. What should I do?
Texas_finest1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-23-2013, 10:48   #2 (permalink)
Moderators
 
Join Date: Apr 2007
Location: Scotland
Posts: 10,875
Re: 03 navigator limited/no heat

Check this , should help you ,

http://www.justanswer.com/ford-linco...-cold-air.html
R.S.LOGAN is offline   Reply With Quote
Old 10-28-2013, 21:44   #3 (permalink)
Registered User
 
Join Date: Aug 2013
Posts: 24
Re: 03 navigator limited/no heat

I'm now thing it may be heater control valve.. How does it work? Engine side of hose is warm but the heater core side is cool... When I start the truck vacuum sucks and engages the valve and when the engine is off it releases. Is this proper operation?
Texas_finest1 is offline   Reply With Quote
Old 10-29-2013, 14:19   #4 (permalink)
Registered User
 
Join Date: Aug 2013
Posts: 24
Re: 03 navigator limited/no heat

I HAVE HEAT. I took off the vacuum line on the heater control valve, plugged it and now the heat is working. I don't know how it works but not worried about it now.
Texas_finest1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.