03 navigator, no power locks or driver window - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-26-2009, 20:45   #1 (permalink)
Registered User
 
Join Date: Jan 2009
Posts: 3
03 navigator, no power locks or driver window

Just went down to the beach (high humidity) and all of the sudden my power locks (inside buttons, keypad, and remotes) and drivers side window all stopped working. I decided to unplug the battery to let everything reset (about 30 mins). Plugged the battery back in, toggled the switches inside about 10-20 times and everything slowly started to work again. Left the car overnight and they stopped working again.

I can hear clicking from the BSM when toggling the switches but the motors never activate. I checked fuse #30 which seems to control both of the functions I'm having issues with but it seems fine (tested and swapped with a good fuse).

Also, the drivers side map light and drivers side rail light stopped working. These are on the same fuse as the vanity mirrors (which are working) but I decided to pull and reseat the fuse anyways. When I did that the map light started working.

Do I need to replace the BSM? Corrosion in the fuse box? Any ideas? Thanks for the help!
jaymd123 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:52.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.