03 Navigator Running Boards - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-21-2010, 19:42   #1 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 72
03 Navigator Running Boards

I have an 03 Navigator and my running boards (door step) do not deploy when I open the door after unlocking it. When I close the door and open it again, the running boards deploy.
Also, sometimes when I close the door, the running board does not go back in, or it lags like 5 seconds or more before going back in.
I am guessing its a motor problem for the running board.
msrdude is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-21-2010, 21:44   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,803
Re: 03 Navigator Running Boards

Sounds like a poor connection. What brand are they?
__________________
Bert
Bert is offline   Reply With Quote
Old 09-21-2010, 22:11   #3 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 72
Re: 03 Navigator Running Boards

I do not know. They are the stock ones.
Is it a poor connection, or is the door hinge area where it latches (or where it touches that button to turn the door light on and off) I need to clean?
msrdude is offline   Reply With Quote
Old 09-22-2010, 09:53   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,803
Re: 03 Navigator Running Boards

That's possibly the buttons. I don't know what the system is like. Ford doesn't put one in at the factory.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:06.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.