03 navigator shakes/vibrates when pressing gas at high speeds - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 05-12-11, 08:33 PM Thread Starter
Registered User
 
Join Date: Jun 2010
Posts: 72
03 navigator shakes/vibrates when pressing gas at high speeds

I have a 03 navigator and when I drive on the freeway like 65 + mph, let go of the gas then press on the gas to speed up, the bottom of the car shakes/vibrates. This happens most of the time and it does not happen when I press on the gas really slow. What do you think is the problem?

msrdude is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-12-11, 09:15 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,310
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

Take it to Autozone and they'll pull codes for free. See what comes up.

Bert
Bert is offline  
post #3 of 9 (permalink) Old 05-12-11, 11:18 PM Thread Starter
Registered User
 
Join Date: Jun 2010
Posts: 72
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

The check engine light is not on though
msrdude is offline  
post #4 of 9 (permalink) Old 05-13-11, 09:24 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,310
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

The light doesn't have to be on to have a code.

Bert
Bert is offline  
post #5 of 9 (permalink) Old 06-29-11, 11:22 AM Thread Starter
Registered User
 
Join Date: Jun 2010
Posts: 72
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

There is no codes. I asked my teacher at school, told him if it could be a transmission problem, or maybe a spark plug problem, and he said it may be the torque converter or something like that. Do you think so too?
msrdude is offline  
post #6 of 9 (permalink) Old 06-30-11, 05:14 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,310
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

It's possible for that or other things. Without being able to experience it, I couldn't say what it is. How many miles on the spark plugs? Does it feel like it's missing?

Bert
Bert is offline  
post #7 of 9 (permalink) Old 07-01-11, 11:22 AM Thread Starter
Registered User
 
Join Date: Jun 2010
Posts: 72
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

Yea, it is the spark plugs. I drove home last night, and the car shook like crazy. I slowed down and the car was shaking and was about to shut off by itself. I could not get the car past 60 mph and it definitely sounded like it was misfiring.
msrdude is offline  
post #8 of 9 (permalink) Old 03-14-13, 08:10 PM Thread Starter
Registered User
 
Join Date: Jun 2010
Posts: 72
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

Update:

This problem has been solved. No mechanics and the first time i took it into the Ford dealer could not figure out the problem. Second time i took it to the Ford dealer, they finally figured out that the transmission was going out. They dropped the tranny opened it, and it was fried. Ended up replacing a new transmission and cost almost 4 grand! Now, car drives smooth and no more jerking when pressing the gas pedal.
msrdude is offline  
post #9 of 9 (permalink) Old 03-15-13, 09:02 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,310
Re: 03 navigator shakes/vibrates when pressing gas at high speeds

Sorry to hear the cost but glad to hear that it's fixed.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome