03 Navigator - What the Heck? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-09-2010, 10:05   #1 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 5
03 Navigator - What the Heck?

Guys/Gals

I purchased an 03 navigator and when I purchased it from the dealer the audio system, GPS and overhead DVD player all worked except for the fact there was no sound. The dealer said is was the amp and supposedly pulled it out to replace it but it's taking a while to find the part. Since they pulled that part I'm having all kinds of issues:

- the automatic liftgate stopped working. It shows a message Liftgate Ajar and it's not ajar.

- my GPS is saying that the DVD in the player is not a MAP DVD when it is the original from Lincoln and worked before

- my air pump for the suspension is coming on more often than it would before

- The automatic locks are not working and displays Data Error

- The automatic running boards are not working and displays Data Error

What the heck did they do. Does something need to be reset? Please help
humnbass is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2010, 12:16   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,817
Re: 03 Navigator - What the Heck?

They might hav unplugged something else while doing what they did. Have you talked to the about this?
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:01.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.