'04 Expedition Horn issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-12-2007, 08:17   #1 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 2
confused '04 Expedition Horn issues

Hello everyone. Have been lurking for some time....finally a question. My wife drives an '04 Expedition....the horn started to sound "funny" a few weeks ago....then lighter, then went to a whining noise, then to a dying cow noise, then off all together. With this progression of noises, should I just order the $55 horn and replace? And is it somewhat easy to get too? Thanks in advance for any information!!!

Mike

p.s. Is there a good source for parts online that everyone uses to avoid dealers?
BigTex1968 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-12-2007, 20:55   #2 (permalink)
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: '04 Expedition Horn issues

Auto Parts Fast at RockAuto is a great source for aftermarket parts. If you want genuine Ford, here's a dealer that sells OEM parts at a discount--http://www.discountfordpartsaty2kford.com/

The horn is easy to get to. If I remember correctly it's just one bolt that holds the bracket. There are two horns, a low note and a high note. Are both horns gone?
__________________
I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline   Reply With Quote
Old 09-13-2007, 04:26   #3 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 2
Re: '04 Expedition Horn issues

Good morning and thank you for your response! Yes, both horns are gone. When you hit the steering wheel or the alarm key fob, nothing.....
BigTex1968 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 10:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.