'04 Expedition Horn issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-12-07, 08:17 AM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 2
confused '04 Expedition Horn issues

Hello everyone. Have been lurking for some time....finally a question. My wife drives an '04 Expedition....the horn started to sound "funny" a few weeks ago....then lighter, then went to a whining noise, then to a dying cow noise, then off all together. With this progression of noises, should I just order the $55 horn and replace? And is it somewhat easy to get too? Thanks in advance for any information!!!

Mike

p.s. Is there a good source for parts online that everyone uses to avoid dealers?

BigTex1968 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-12-07, 08:55 PM
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: '04 Expedition Horn issues

Auto Parts Fast at RockAuto is a great source for aftermarket parts. If you want genuine Ford, here's a dealer that sells OEM parts at a discount--http://www.discountfordpartsaty2kford.com/

The horn is easy to get to. If I remember correctly it's just one bolt that holds the bracket. There are two horns, a low note and a high note. Are both horns gone?

I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline  
post #3 of 3 (permalink) Old 09-13-07, 04:26 AM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 2
Re: '04 Expedition Horn issues

Good morning and thank you for your response! Yes, both horns are gone. When you hit the steering wheel or the alarm key fob, nothing.....
BigTex1968 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome