04 Expedition intermittent problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-21-07, 06:58 PM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 2
04 Expedition intermittent problem

We purchased a Ford Certified 04 Expe, several months after we started seeing a intermittent problem with the turn signals. They will all work then suddenly one will stop flash but the light will stay lit. After several stops and restarts they will begin working. I've check all the bulbs, and they look good. Has anyone experience this before?

TIA
Fed
fed.gallardo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-21-07, 07:00 PM
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: 04 Expedition intermittent problem

Looking good doesn't always mean working good. If a filament breaks loose and flops around it can make intermittent contact with the post. Since they're so cheap, start by replacing them. If you still have a problem, then look at the wiring harness connector at the multifunction switch.

I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline  
post #3 of 3 (permalink) Old 09-24-07, 12:39 PM Thread Starter
Registered User
 
Join Date: Sep 2007
Posts: 2
Re: 04 Expedition intermittent problem

Thanks, I will check the bulbs more closely. I hope it is just that.
fed.gallardo is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome