04 Expedition Strange noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-29-09, 12:37 AM Thread Starter
Registered User
Join Date: Dec 2008
Location: Germany
Posts: 5
frown 04 Expedition Strange noise

since a few days i have strange noise in my Ford Expedition. Car is driven with LPG. Since LPG 22.000 klm, total 60.000 klm.
LPG is a Prins VSI with Flashlube, Engine is Ford Triton 5.4 L V8 2004
Inspection and LPG Inspection (Filter change) 1500 klm ago, noise since 500 klm.
Engine cold -> tapping (rattle) with LPG, no noise with gas
Engine hot -> tapping (rattle) with LPG and with gas
What could that be ? Hopefully not the valves ???? Cold it be, that the autoworkshop set the motor control too lean ? Need since the inspection less LPG (fall from 22 to 20 l/100 klm) and less gas (fall from 19 to 18 L/100 klm)

Best wishes
Brigitte + Hans
Ford Expedition + Suzuki Samurai
de8g1310 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome