04 Ford Expedition - Fuel Pump Issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-15-2013, 13:31   #1 (permalink)
Registered User
 
Join Date: Nov 2013
Posts: 2
04 Ford Expedition - Fuel Pump Issues

Need Help! I figured out I'm NOT getting pressure in my fuels lines. Could it be my fuel pump? My Fuel Pump Inercia Switch will not "Stay down" when I press the button to reset. Could it be that? anyone else experience this problem? Don't have the $$$ to take it to a shop, so any help would be appreciated. Need to get this thing running ASAP! Thanks...
Andre LaDuke is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-15-2013, 15:54   #2 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,326
Re: 04 Ford Expedition - Fuel Pump Issues

A more likely cause could be the fuel pump driver module. It's located behind the drivers rear wheel well. Usually can see the corrosion and holes on the back side of it. I would check codes first to be safe. Then maybe take a look at the driver module


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 11-18-2013, 13:39   #3 (permalink)
Registered User
 
Join Date: Nov 2013
Posts: 2
Re: 04 Ford Expedition - Fuel Pump Issues

My local Ford dealer says my make/model does NOT have a Fuel Pump Modual?
Andre LaDuke is offline   Reply With Quote
Old 11-18-2013, 21:01   #4 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,326
Re: 04 Ford Expedition - Fuel Pump Issues

I think I may be wrong. I'm sorry. 04 may still be the 2valve motor which does not use a driver module. It could be 05 that switched to the 5.4 3 valve and began using it. In that case if power and ground good to the pump it could be faulty. Sorry again


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 11-19-2013, 19:12   #5 (permalink)
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 4,044
Re: 04 Ford Expedition - Fuel Pump Issues

Check continuity across the inertia switch, if none, try jumping across it to see if you get pressure, if so, replace the switch.

__________________
'Scuse me, while I scrape this Honda outta my treads.
CatSkinner is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:33.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.