04 lincoln Navi Cruise Control not working HELP - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 04-18-11, 02:21 PM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 10
04 lincoln Navi Cruise Control not working HELP

i have a 04 Navi, the cruise has not worked since i got it, i have check and checked the fuses, brake lights are working fine as well. any ideas of how to test the cruise to see whats going on. when i press the cruise button NO lights come on or anything, i drive over 50 miles round trip to work everyday and really want the cruise working, PLEASE help. thanks
soloblazer is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 04-19-11, 05:47 PM
Registered User
 
Join Date: Apr 2011
Posts: 17
Re: 04 lincoln Navi Cruise Control not working HELP

What button are you pushing for cruise? do all your other steering wheel buttons work? Any ABS lights on or Engine lights on?
tommysauder is offline  
post #3 of 25 (permalink) Old 04-20-11, 06:53 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 10
Re: 04 lincoln Navi Cruise Control not working HELP

i try to press the on button and the others as well. the all the right side steering wheel controls work just fine. on the left side the voice button works fine, but the rest do not do anything, the cruise light never comes on at all. No airbag light, and no check engine light are on. hope this helps. thanks i thought it might be the clockspring, i guess it still could be, but everything else is working fine.
soloblazer is offline  
post #4 of 25 (permalink) Old 04-20-11, 11:56 AM Thread Starter
Registered User
 
Join Date: Jul 2010
Posts: 10
Re: 04 lincoln Navi Cruise Control not working HELP

i have narrowed it down to the PCM, now is it worth the $800 for new pcm and flashing it to have cruise???? this stinks.
soloblazer is offline  
post #5 of 25 (permalink) Old 04-22-11, 01:49 AM
Registered User
 
AlwaysFord's Avatar
 
Join Date: Jan 2011
Location: Clarksville, Tn.
Posts: 113
Re: 04 lincoln Navi Cruise Control not working HELP

How did you narrow it down to the pcm? Secondly, there are lots and lots of other factors that can keep your cruise control from initiating. Obviously, fuses. Check them all. You never know. Sometimes the "Radio" fuse can be controlling one simple part of the system that you need right now. Check in applicable relays and all switches related.This is a common Ford problem, and have never heard of it being the PCM. I will see if I can do some more research on your system, and get back with you.

2001 Ford Expedition Eddie Bauer 4x4 (mine)
2003 Ford Focus SE (the wifey)
AlwaysFord is offline  
post #6 of 25 (permalink) Old 04-22-11, 01:57 AM
Registered User
 
AlwaysFord's Avatar
 
Join Date: Jan 2011
Location: Clarksville, Tn.
Posts: 113
Re: 04 lincoln Navi Cruise Control not working HELP

Check your brake deactivation switch on your master cylinder. Make sure everything is within spec on it. That is the most common Ford cruise control problem.

2001 Ford Expedition Eddie Bauer 4x4 (mine)
2003 Ford Focus SE (the wifey)
AlwaysFord is offline  
post #7 of 25 (permalink) Old 01-01-15, 12:39 PM
Registered User
 
Join Date: Jan 2015
Posts: 8
Re: 04 lincoln Navi Cruise Control not working HELP

Soloblazer, long time ago, but die you found the fault? Mine cruise control want also not. Tried everything but found nothing. I'm desperate
NavigatorV8 is offline  
post #8 of 25 (permalink) Old 01-01-15, 03:05 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,470
Re: 04 lincoln Navi Cruise Control not working HELP

First, is there any other issues? Codes, such as misfire, etc.? If everything else is normal, have you tried this test procedure?

http://www.justanswer.com/ford-linco...t-working.html

Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
post #9 of 25 (permalink) Old 01-02-15, 01:34 AM
Registered User
 
Join Date: Jan 2015
Posts: 8
Re: 04 lincoln Navi Cruise Control not working HELP

yeah, i performed the procedure. no other fails like misfire etc.
NavigatorV8 is offline  
post #10 of 25 (permalink) Old 01-02-15, 06:04 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,470
Re: 04 lincoln Navi Cruise Control not working HELP

I've got a few diagrams for you, one of your inputs must be giving you an issue. Pay particular attention to what AlwaysFord had posted.







Chewing on asphalt and drinking dinosaur wine
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome