05 Lincoln Navigator - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-15-10, 06:21 AM Thread Starter
Registered User
 
Join Date: Feb 2010
Posts: 1
05 Lincoln Navigator

Rear DVD wont power on and the control for it on the navigation system is not there. Any help would be greatly appreciated.

Thanks

helluva is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-18-10, 05:16 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 05 Lincoln Navigator

Did you check all your fuses? Under hood and under the dash?

Be sure that all connections are also tight. I realize they might not be easy to access, but it's worthwhile to check. Sometimes the assemblers can get lazy.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome