06 expedition popping and surging - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-14-2010, 18:39   #1 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 4
06 expedition popping and surging

i have an 06 expedition that at wide open throttle pops back through throttle body and suges at wide open throttle while accelerating.it is almst like it is runnig out of gas.it has no codes.any input on this would be appreciated.
al74 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-14-2010, 19:47   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,763
Re: 06 expedition popping and surging

If you're at wide open throttle, it's probably the rev limiter. It doesn't allow the the engine to overrev. If you shift it into a low gear and accelerate, it does that at the max allowable RPM. If it does it in a gear before it shifts, it could be a clogged fuel filter.
__________________
Bert
Bert is offline   Reply With Quote
Old 01-14-2010, 20:09   #3 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 4
Re: 06 expedition popping and surging

it is doing it from 3500 to 4500 rpm during acceleration.i replaced fuel filter as well as all injectors.it just has started doing this recently.it use to open up and run fine.i have also noticed a slight skip in the engine at idle and when you start to back up.could it be the fuel pump?this has really got me puzzled.
al74 is offline   Reply With Quote
Old 01-15-2010, 08:17   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,763
Re: 06 expedition popping and surging

You'd need a gauge to check the fuel pump pressure. Another test is a volume thest. Run the pump for about 30 sec. and you should get about a qt, of fuel. Not running of course.
__________________
Bert
Bert is offline   Reply With Quote
Old 01-15-2010, 10:04   #5 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 4
Re: 06 expedition popping and surging

thanks for taking time to help.i will check this out and see what happens.i'll let you know.
al74 is offline   Reply With Quote
Old 01-19-2010, 21:45   #6 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: 06 expedition popping and surging

Same thing is happening to my 2006 Ford Expedition, when I get on the freeway and give it a lot of gas, when my tach hits after 3k I get couple backfire out of the intake, and surges bad. The OBD-II on our SUV provides the fuel rail pressure and that was the 1st thing I checked was I plugged in my Actron CP9185 OBD-II Scan tool, the PSI stays between 38-40PSI when I am driving, and when I hit on the gas where the problem shows up at 3k the fuel pressure shows no sine of problem it still stays with in 38 to 40PSI. It reports misfire on different cyl each time. But would a misfire cause it to backfire through the intake?

I also found that my fuel trim on the left bank is riching up by 20% on the long term fuel trim while under load while the right bank is riching up by 5%, and I also found that the o2 post cat on the right bank is showing same switch rate as the pre-cat as if I have cat problem. I would like to replace all my spark plugs but I need to lern how to remove that fuel rail, shops want to charge $300 - $400 for the spark plug change.
YFZ450Lynx is offline   Reply With Quote
Old 01-20-2010, 16:43   #7 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: 06 expedition popping and surging

I just found a Tech Service Bulletin TSB 06-13-9 stating there is problem on 2006 Expedition at 3500 - 4500 RPM that required the PCM to be flashed with the last Calibration file from ford. I will replace my plugs and see if its still there, and if it is, I am taking it down to the dealer to get my PCM flashed to the latest flash.
YFZ450Lynx is offline   Reply With Quote
Old 01-20-2010, 17:06   #8 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,763
Re: 06 expedition popping and surging

Good find. Post back so we know the outcome.
__________________
Bert
Bert is offline   Reply With Quote
Old 01-23-2010, 20:22   #9 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 4
Re: 06 expedition popping and surging

i had mine updated and it did not fix my problem.if you figure out what is causing this please let me know.even though my fuel pressure is staying at 39psi or more.everyone i have talked to locally says that a pump will fix it.i may bite the bullet spend $250 and try it.i hope it is not the plugs.everybody says they are almost impossible to get out without breaking off in the head.any advice on getting plugs out.
al74 is offline   Reply With Quote
Old 01-26-2010, 10:01   #10 (permalink)
Registered User
 
Join Date: Jan 2010
Posts: 7
Re: 06 expedition popping and surging

My surging problem is now cure. By replacing plugs and a bad coil on cyl #6.

But I still have some popping at 4,500RPM range at WOT that trips the CEL to blink and put the car in failsafe mode Fuel System "OPEN2" due to Cyl #3 misfire. I put a new coil on Cyl #3 as well no luck so I ran fuel injection cleaner and still no luck. My catalytic convert is now showing up bad on the OBD-II (DTC P0430) probably due to the major misfire before the plug changes. I now have a strong pull from take off to 4,500 RPM the 3k RPM range is no longer my dead zone any more. I am starting to wonder if my problem on cyl #3 is cam/valevs problem because it only happens at high revs with WOT. Bringing the RPM up with slight throttle I don't get misfire, so i thinking when its WOT the computer adjusted the Cam far enough that my valves are are slightly still open when it sparks. This would mean my intake valve might be too tight on the cam lobe just on cyl #3 since that is the only one giving me issues, I will do compression test when its not so raining and cold out.
YFZ450Lynx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum

Related Reading: 06 expedition popping and surging


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:40.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.