06 Expediton Bauer brake question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-25-09, 12:01 PM Thread Starter
Registered User
Join Date: Aug 2009
Posts: 2
06 Expediton Bauer brake question

Hi, New to the forum as well as an owner of a Ford Expedition. I have question regarding the brake system. I have replaced all the rotors and brake pads on the front and rear and as I was putting back the wheel on the front driver side I noticed this small plastic/rubber tube hanging above the chassis close to the brake lines. It does not go anywhere (open) and tracing back it ended up on the back of the hub. I was afraid I might have disconnected this somewhere but I could not see anything that it might have come from. The passenger side have the same thing and when I traced it it went to the driver side. i was thingking this could be a breather for moisture in the hub. Any input is much appreciated. Also after test driving the truck the ABS light went on when I was sitting/breaking in the brake pads. This happened after driving the truck on 60 and then braking slowly until 10mph for about five times. When I saw the ABS light I stopped the truck and then started again, it stayed for maybe 30 sec and then it went away and has not come back. I was thingking that it sensed that the brakes are tight because they were new and I bleed the whole system. is this something I should worry about. I am mechanically inclined but have not dealt with electronics on newer cars.

Thanks in advance
rtromero is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome