'07 Expedition El - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-14-2008, 21:39   #1 (permalink)
Registered User
 
Join Date: Mar 2008
Posts: 1
confused '07 Expedition El

ALOHA,

I HAVE A EXPEDITION EL '07 I HAVE TAKEN MY CAR IN TWICE TO HAVE A MECHANIC VERIFY A THUG NOISE WHILE REVERSING. ON THE FIRST INITIAL REVERSE WHILE BACKING INTO A STALL THERE'S A THUG NOISE AS IF YOU BANGED A KID OR ANIMAL ( I KNOW SCARY SOUND). THE MECHANIC CAN'T VERIFY THE NOISE ON PAPER, EVENTHOUGH HE HEARD IT ON A TEST DRIVE WITH ME. DID ANYONE EXPERIENCE THIS BEFORE?

THANKS FOR YOUR TIME.....
deboma is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-30-2008, 08:59   #2 (permalink)
Registered User
 
Join Date: Jun 2008
Posts: 1
Re: '07 Expedition El

I have heard that on mine also.. I thought I was just crazy or that I ran over something. Plus it doesn't help that when my husband drives it, he never hears it!
cctxmom is offline   Reply With Quote
Old 07-22-2008, 18:01   #3 (permalink)
Registered User
 
Join Date: May 2008
Posts: 8
Re: '07 Expedition El

Just go to the dealer and tell them about TSB07-25-5.

It relates to hesitation after tip-in from a stopo/bump while bracking to a stop. Vehicles built before 12/3/2007
FRANK K is offline   Reply With Quote
Old 07-22-2008, 18:11   #4 (permalink)
Registered User
 
Join Date: May 2008
Posts: 8
Re: '07 Expedition El

Let me point out to you first is only when you back up if so this may not apply?? This with fix it if it is happening when you are stopping or starting from a stop. At my Dealership they told me it works both ways. Only one way to find out. Ask yours.
FRANK K is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.