1998 Expedition-No Power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-27-07, 08:11 AM Thread Starter
Registered User
Join Date: Jan 2006
Posts: 2
confused 1998 Expedition-No Power

My wife drives a 1998 EB Expedition w/ 5.4 Triton V-8 and 128,000 miles. This summer we noticed the vehicle losing power, particularly when we towed our pop up camper through the mountains. Prior to this summer we could cruise up the Rockies at 75 with the a/c running and fully loaded- this summer we can barely break 45. We have maintained the vehicle well ahead of schedule and recently had all fluids changed, a tune up and the injectors cleaned but no improvement. The other night while driving to Colorado Springs the check engine light began flashing and the truck started hesitating drastically. Our mechanic has been all through the vehicle and says he cannot find the source of the problem
djb-co is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-05-07, 06:16 PM
Registered User
Join Date: Nov 2007
Posts: 4
Re: 1998 Expedition-No Power

Here is the problem. If the check engine light was flashing there was a misfire in one of the coil packs or in the plugs. I have a 1999 EB 5.4L with 176K on it and I have owned it since it had 55,000 on it. The reason that the light might have went off or there was a consistent problem might be because the moisture settled or burned off. My did this sparatically one like your when I had a bit of moisture in the coil. Upgrade your intake and check your coil paks.
Expo99Guy is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome