2 Issues, Parking Brake & Mirrors - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-30-09, 11:36 AM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 6
frown 2 Issues, Parking Brake & Mirrors

Ok, first problem is my parking brake no longer automatically releases in my 03 navigator, I am thinking its mabye the solonoid? It also usually does not show up the parking brake light on the dash so mabye theres a sensor that isnt telling the car the brake is on?

2nd problem is my mirrors, they jitter and hesitate when moving and sometimes dont go back to the proper position after going from reverse to drive. Motors need cleaning/greasing or should I replace?

lemgomez is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-31-09, 05:35 PM Thread Starter
Registered User
 
Join Date: Oct 2009
Posts: 6
Re: 2 Issues, Parking Brake & Mirrors

/bump

Anyone?
lemgomez is offline  
post #3 of 3 (permalink) Old 10-31-09, 06:32 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,300
Re: 2 Issues, Parking Brake & Mirrors

I would say to look under the dash where the park brake pedal is and see if something got dislodged. I think they were run by vacuum and the hose could have come off. Do you hear a slight hiss when you put it in gear? The switch that controls the light is mounted on the park brake assy. One wire that ground when the brake is applied. It has a light green/ red wire to it.

I can't say much about the mirrorsexcept to see if they are loose to the touch. with your hand, try to move them amd see if they seem like they are loose. They should move with a little tension but not a rattle kind of movement.
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome