2000 eddie bauer expedition sat for 3 years - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-21-09, 08:33 AM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 2
2000 eddie bauer expedition sat for 3 years

my dad has a 2000 expedition it sat in the driveway for 3 years he told me to come and get it, but wheni crank it, the engine turns good but it doesnt turnover, it has gas, a 1/4 tank, i cleaned out the throttle body and sprayed down inside the intake and the crankt he truck and it will turnover until the spray ran out, i think it is a gas problem, i hear the fuel pump pressurizing. do you guys have any ideas what else it could be? i also reset the fuel shut off valve in the kick panel.

chisan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-21-09, 01:29 PM
Registered User
 
Join Date: Apr 2009
Posts: 17
Re: 2000 eddie bauer expedition sat for 3 years

Might want to put a fuel pressure gauge on the rail to see if there is anything there or not. Also, you could pull off the output of the low pressure pump to see if you are getting flow.
gjensen is offline  
post #3 of 3 (permalink) Old 04-30-09, 08:42 AM Thread Starter
Registered User
 
Join Date: Apr 2009
Posts: 2
Re: 2000 eddie bauer expedition sat for 3 years

i found out it was the fuel pump, and the fuel filter, along with mis-matched spark plugs, changed them all out, added alittle seafoam and the car purrrrs, lol thanks guys
chisan is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome