2000 Expedition gas pedal stops working at light - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2011, 13:36   #1 (permalink)
Registered User
 
Join Date: Oct 2011
Posts: 2
2000 Expedition gas pedal stops working at light

The gas pedal on my 2000 Ford Expedition stops working intermittently. The engine idles fine but no amount of pressure on the pedal with work to move the car. The engine will not rev at all, just idle. Once i restart the car the pedal starts working again.

When the problem occurs, I have tried shifting the car in and out of park and neutral, but it does not fix the problem until the car is restarted.

This has happened twice while stopped at a light, and once will moving at about 30 MPH.

Anyone have any ideas about what the problem is? It makes me pretty nervous...
munky000527 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-19-2011, 19:28   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: 2000 Expedition gas pedal stops working at light

The 2000 has a cable to the throttle body. When it's doing that, have someone push the pedal and watch the linkage to see what's occuring.
__________________
Bert
Bert is offline   Reply With Quote
Old 10-20-2011, 02:02   #3 (permalink)
Registered User
 
Join Date: Oct 2011
Posts: 2
Re: 2000 Expedition gas pedal stops working at light

I thought that it could be the TPS, but even if it quit working intermittently, wouldn't the computer still detect an increase in flowing air when I pressed the pedal and up the fuel input, which would cause the engine to rev? I checked it, removed it, and cleaned it anyway, but everything there looks fine.

I also checked the cable and the way it moves, but everything there looks fine, too, including it's interaction with the throttle body plate...
munky000527 is offline   Reply With Quote
Old 10-20-2011, 08:14   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,658
Re: 2000 Expedition gas pedal stops working at light

If it stays at idle with the throttle open, something has to be binding or not opening. If it opens the RPMs have to increase or run bad due to other defective part. Go to Autozone and see what codes they may pull.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.