2000 Expedition Oil Pressure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-13-2014, 20:40   #1 (permalink)
Registered User
 
Join Date: Feb 2014
Posts: 2
2000 Expedition Oil Pressure

Hello - new here but familiar with the fantastic assistance available here.

I have a 2000 Expedition that seems to be coming unglued after 205k trouble free miles. After getting the car back from an Indie who replaced the #5 coil, all spark plugs, and fuel filter due to poor starting and hestitation/stuttering, the following day I went to start the the car for first time and got the Oil Pressure/Engine Coolant light with a corresponding Engine Oil Pressure Gauge reading Low. Neither indicator had ever previously been an issue. Since then, I get both indicators in unison immediately after startup, stay on for a few minutes and illuminate intermittantly before extinguishing after 5-10 minutes after initial start.

Is this more likely a loose wire or cable to a sensor after the servicing, and does it likely represent a non-critical condition? I don't drive the car often, so I have time to troubleshoot without a huge impact.

BTW, the diagnosed #5 misfire remedy did not solve the initial issue of difficult starting and stuttering while accelerating after a stop.
Florida2000Exp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-14-2014, 11:44   #2 (permalink)
Moderators
 
r-clar's Avatar
 
Join Date: Feb 2013
Location: Demotte Indiana
Posts: 1,326
Re: 2000 Expedition Oil Pressure

Done quite a few oil pressure sending units on those over the years for exact concern. Cheap enough part and pretty easy to change. Normally I say diagnose but in this case I would just change it. As far as your stutter I would suspect misfire. Would need someone with capability to see what cyl. To accurately diagnose.


Sent from AutoGuide.com App
r-clar is offline   Reply With Quote
Old 02-14-2014, 17:24   #3 (permalink)
Registered User
 
Join Date: Feb 2014
Posts: 2
Re: 2000 Expedition Oil Pressure

Will do --Thank you!
Florida2000Exp is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.