2000 expidition electrical problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-28-11, 12:50 PM Thread Starter
Registered User
 
Join Date: Oct 2011
Posts: 1
2000 expidition electrical problems

Hi Im new at this and hope that someone can help. I have a 2000 expidition and recently started to have problems. It wont start unless the drivers side door lock switch is held in the lock position while trying to start the vehicle. the interior lights blink off and on and the speedometer peaks out then drops back to zero when this happens as well. any ideas?

jody392 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-28-11, 05:45 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,312
Re: 2000 expidition electrical problems

Probably a connection problem somewhere. Power or ground. If it' doing it all the time would be an easier fix than if it's intermittant. Is the battery fully charged? You could try unplugging and replugging the connectors in the kick panels, under the steering column area, and under the hood.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome