2001 Expedition acceleration problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-29-2013, 18:43   #1 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 2
2001 Expedition acceleration problems

The problem I am having is when I come to say a yield sign and I'm braking but don't come to a complete stop and try to accelerate my truck just doesn't wanna gland feels almost like its gonna stall. Could it be the IAC?
ngmillar is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-29-2013, 18:46   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: 2001 Expedition acceleration problems

Autozone will check codes for free. That would help narrow it down.
__________________
Bert
Bert is offline   Reply With Quote
Old 07-29-2013, 19:01   #3 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 2
Re: 2001 Expedition acceleration problems

Quote:
Originally Posted by Bert View Post
Autozone will check codes for free. That would help narrow it down.
Well the problem with that is whatever the problem is it isn't causing the check engin light to come on
ngmillar is offline   Reply With Quote
Old 07-29-2013, 19:56   #4 (permalink)
Registered User
 
Join Date: Jul 2013
Posts: 24
Re: 2001 Expedition acceleration problems

Look in tech manual for multi meter test of mass air flow sensor. Have had several cars with a bad mass air flow and no code in the computer don't know if it'll help or not but at least it's something to check

Sent from AutoGuide.com Free App
brad76017 is offline   Reply With Quote
Old 07-30-2013, 08:15   #5 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,758
Re: 2001 Expedition acceleration problems

Also, the light doesn't have to be on for a code to be present. If you unhook anything before checking for codes, that will show a code.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:11.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.