2001 Expedition battery light - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-10-07, 12:20 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
2001 Expedition battery light

2001 Expedition battery light came on and truck died. I had the alternator checked at NAPA and they said it was good. I bought a MAXX battery at Wal-Mart with a 850 cca rating. Worked fine for 1/2 hour then the battery light came on and stayed on. It is a steady light. The battery guage stays in the middle. The truck starts fine. When i put the alternator back on, I lost the brass nut that holds the wire coming from the battery to the alternator. I put a regular nut on in it's place. What is the reason the battery light is staying on? Could it be a loose belt? Thank you for the help.

bdgoudy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-10-07, 07:49 PM
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: 2001 Expedition battery light

Do you know if the battery you bought had a full charge in it? An alternator cannot charge a discharged battery. Try charging the batt with a charger. With a full charge on the battery (at least 12.6 volts), start up the vehicle, turn on all the lights and the blower and rev to 2000 rpms. Then check the voltage at the battery. If it reads less than 13.4 volts, your alternator is bad.

Or, you have a bad ground wire.

I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline  
post #3 of 3 (permalink) Old 08-10-07, 08:25 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
Re: 2001 Expedition battery light

I didn't even think the battery might not be charged. I assumed that the alternator charged the battery. I know just enough about cars to break them. I will put the battery on a charger overnight and then try it in the morning. Thanks for the help, I appreciate it.
bdgoudy is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome