2003 Expedition A/C vacuum line - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-02-11, 05:36 PM Thread Starter
Registered User
Join Date: May 2011
Location: Los Angeles
Posts: 1
2003 Expedition A/C vacuum line: Solved

The A/C was blowing out through the defroster vents and I could'nt change it, I found a very thin broken vacuum line near the fire wall in the engine compartment, after I repaired it, it was working fine. Today I had the same problem with the vent control, when I checked the vacuum line again it had broken off at the fire wall and fallen in behind the dash and I cannot find it.
I would like to run a new line but I dont know where to connect it. Is there a diagram or a picture of where it connects to under the dash?? Thanks

Solved: Turns out the small vacuum hose does not go through the fire wall, there is actually a hose socket in the fire wall it just pushes into..
Kevdog is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome