2003 Expedition Radio has no power - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-25-12, 03:31 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 4
2003 Expedition Radio has no power

I have a 2003 Exp. I replaced radio and shorted wire while installing. I assumed it was a fuse under right side of dash but could not find any blown fuses. Then I thought it was radio so I re-installed factory radio. It did not work either even though it worked when I removed.

Are there other fuse locations? Any suggestions on what fuses/relays to check?

Thanks in advance.

mstarkey is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-25-12, 04:45 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2003 Expedition Radio has no power

Did you check fuse #7? #4 too if it has a rear dvd.

Bert
Bert is offline  
post #3 of 8 (permalink) Old 02-25-12, 05:57 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 4
Re: 2003 Expedition Radio has no power

yes, i checked those both. I will check again in case I made a mistake but I have a tester as well
mstarkey is offline  
post #4 of 8 (permalink) Old 02-25-12, 06:35 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2003 Expedition Radio has no power

Which radio was in there?

Bert
Bert is offline  
post #5 of 8 (permalink) Old 02-25-12, 07:24 PM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 4
Re: 2003 Expedition Radio has no power

the factory radio was in their originally and it included a DVD player. I replaced it with an aftermarket stereo. once the new one would not work, i placed original one back in and it did not work either which told me a fuse had blown. i just cant find it.
mstarkey is offline  
post #6 of 8 (permalink) Old 02-25-12, 07:59 PM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2003 Expedition Radio has no power

The fuses that run the radio are 2.4, 2.7, 2.22, and 2.31.

Bert
Bert is offline  
post #7 of 8 (permalink) Old 02-26-12, 05:12 AM Thread Starter
Registered User
 
Join Date: Feb 2012
Posts: 4
Re: 2003 Expedition Radio has no power

Bert,

Thank you very much. It was fuse 2.31 and I had not checked it before for some reason. Thanks again as it is now working!!

Mike
mstarkey is offline  
post #8 of 8 (permalink) Old 02-26-12, 07:43 AM
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 10,298
Re: 2003 Expedition Radio has no power

Glad to hear. Thanks for the update.

Bert
Bert is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome