2003 expedition rattle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-21-07, 05:22 PM Thread Starter
Registered User
 
Join Date: Mar 2007
Posts: 4
2003 expedition rattle

hey all....still really new to this, but here goes..i have a 2003 expedition and when i hit some train tracks, or a small pot hole, i hear kind ofa little rattle...i was thinking it was the suspension, but im not sure. I have alloy wheels with stock center covers that seem to be on tight. any ideas would be greatly appreciated.

digga426 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-22-07, 05:57 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 45
Posts: 1,486
Re: 2003 expedition rattle

The swaybar links will wear out on those models and cause a "rattle" noise over bumps.
Johnny Mullet is offline  
post #3 of 10 (permalink) Old 04-29-07, 05:01 AM
Registered User
 
Join Date: Mar 2007
Location: St Louis, Mo
Posts: 250
Re: 2003 expedition rattle

Quote:
Originally Posted by Johnny Mullet
The swaybar links will wear out on those models and cause a "rattle" noise over bumps.
Get a set of neoprene replacements for it.

I love it when people do things right
Unfortunetly I dont always do that lol
Sand1 is offline  
post #4 of 10 (permalink) Old 06-22-07, 05:54 PM
Registered User
 
Join Date: Jun 2007
Location: colleyville,tx
Posts: 11
Re: 2003 expedition rattle

My wife had that same problem. If you look on the back of the lift gate, the license plate bracket might only have the top screws in it making it rattle.
chevy=garbage is offline  
post #5 of 10 (permalink) Old 07-08-07, 04:19 PM
Registered User
 
Join Date: Jul 2007
Posts: 12
Re: 2003 expedition rattle

i have the same problem on my 99. Looked everywhere i could to find something loose and recently discovered that the steering shaft is worn out. you might try wiggling your and see if its worn out.
rick555 is offline  
post #6 of 10 (permalink) Old 11-20-07, 10:56 PM
93 Ford Expedition 4.6L
 
Join Date: Nov 2007
Location: Sandy Eggo
Posts: 9
Re: 2003 expedition rattle

I have the same problem but when the brake is lightly pressed while driving over the center lane bumbs the rattle silents and comes back when let go.. I thought it was the brake pads vibrating.?
MorningWud is offline  
post #7 of 10 (permalink) Old 03-17-15, 11:16 AM
Registered User
 
Join Date: Mar 2015
Posts: 1
Re: 2003 expedition rattle

Had the same problem you describe, mine was missing a caliper retaining clip. Check both sides as I found one missing, mechanic must have missed it last pad change.
Oramoslopez is offline  
post #8 of 10 (permalink) Old 03-17-15, 11:23 AM
Moderators
 
R.S.LOGAN's Avatar
 
Join Date: Apr 2007
Location: Scotland
Posts: 14,917
Re: 2003 expedition rattle

Probably got it fixed as post is more than 7 yrs old .
R.S.LOGAN is offline  
post #9 of 10 (permalink) Old 08-16-15, 11:22 AM
Registered User
 
Join Date: Aug 2015
Location: Indianapolis, IN
Posts: 1
Re: 2003 expedition rattle

I just joined the Forum today....and my rattle is the doors! I used a torx socket -loosened the door latch and re-positioned them closer to the interior - so that the door has to close more tightly in order to physically latch. It seemed to help. Question...how can I re-position the other part of the latch that's actually inside the door itself? My guess is that at 175,000 miles that the rubber seals have flattend over time ?
pwdalbey is offline  
post #10 of 10 (permalink) Old 08-16-15, 02:28 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,937
Re: 2003 expedition rattle

After 175K and 12 years of opening and shutting, things shift, loosen, and deform. You're on the right track.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome