2003 Expedition: SES Light, spark issue - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-22-2008, 06:43   #1 (permalink)
Registered User
 
Join Date: Dec 2008
Posts: 1
2003 Expedition: SES Light, spark issue

I have seen several references to 2003 Expeditions sputtering, idling rough, and dying.

I am having this very issue.

The SES Light comes on, blinks for a little bit at a slow pace, and then eventually goes solid. While sitting, you can feel the strong vibrations.

No codes on a diag computer.

I believe it's one or more of the sparks. Now.. from what I understand, the 2003 Expeditions don't use Spark plugs per se, but they use something else... the name escapes me.

My dad ask one of his mechanic buddies what it could be and he said the that spark on the back of the engine on teh drivers side, and the front one on the passengers side are the top two to go out.

My father and I are not rookies when it comes to car work, but I have heard how getting to the sparks are a pain.

I have also read where this could be a vacuum issue.

I believe my Ext. Service Plan is still good, and I only have a $50 deductible, so if the plan is still good, I am probably just going to take it to the dealership.

But I am just researching this for my own edification. Any advice, suggestions would be appreciated.

THANKS!
x-angel is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-26-2008, 19:26   #2 (permalink)
Registered User
 
RickMN's Avatar
 
Join Date: Jul 2007
Posts: 231
Re: 2003 Expedition: SES Light, spark issue

There's a TSB on leaking coolant hose that drips coolant onto the coil pack below it. But in general, Ford's are notorious for burning out coil packs. In fact, you can probably count on replacing all of them before you hit 150M miles. If you have the 5.4 triton engine, there's a HUGE problem removing spark plugs and having spark plugs blow out of the hole. It's critical that you do NOT run those plugs all the way to 100M miles. They rust in place and take hours to get out. Ford has about a zillion TSBs on this problem alone.

Take this to your dealer if you still have the extended warranty. That will probably cover the coil pack. But I've heard that a lot of the extended warranties are denying coverage on stuck spark plugs because spark plugs are excluded under the coverage.

Here's an article on coil packs: Ford coil packs
__________________
I'm a retired ASE Master/L-1 Technician. I still keep current with the latest automotive technology. Visit my blog for cool articles and TSB's: http://www.ricksfreeautorepairadvice.com/
RickMN is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:15.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.