2003 Expedition XLT Airbag light? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-22-2009, 14:11   #1 (permalink)
Registered User
 
Join Date: May 2009
Posts: 1
Exclamation 2003 Expedition XLT Airbag light?

My airbag light on my Expo just came on and it flashes 3 times then goes solid about a minute or two after I start the truck. Any ideas on what this code is and means?
03expocustom is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-26-2009, 17:31   #2 (permalink)
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,475
Re: 2003 Expedition XLT Airbag light?

Sounds like a standard fault to me. With the light on, one, or both air bags will probably not work if you were to be involved in a collision. If you have side or side curtain air bags, those may be affected as well. With the CEL on, you can get the vehicle scanned for codes to better narrow down the problem. Without knowing for sure the exact code, myself, or others for that matter can only guess on what the problem is. Worst case is the clock spring is causing problems, and requires removing some steering wheel components - and the drivers air bag, to replace. Keep us posted with any updates!
__________________
'00 Durango R/T 360ci 290hp (modded); 138,500m
'06 Pontiac G6 GT 3.5L 220hp; 44,000m
'12 Chrysler 200 Limited 3.6L 283hp; 13,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 03:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.