2003 Ford Expedition Coils - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-30-2012, 11:07   #1 (permalink)
Registered User
 
Join Date: Apr 2012
Posts: 2
2003 Ford Expedition Coils

Hey yall,

We have a 2003 Ford Expedition with about 51K miles on (very low miles). About a month ago, the service light came on, indicating a misfire on cylinder #7; we had the coil replaced, and all was well for about a week. The service light came back on...and again, indicated a misfire on cylinder #7. We took it in to get checked out, and the brand new coil was bad. Is that normal? I've heard that these vehicles are notorious for coil problems...but I'm worried there could there be something else wrong to cause the coil to go bad? Any thoughts? Thanks!
ws1122 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-30-2012, 12:25   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,748
Re: 2003 Ford Expedition Coils

They don't have that much trouble with the coils. Was the coil a Ford (Motorcraft) brand? The aftermarket coils don't last long.
__________________
Bert
Bert is offline   Reply With Quote
Old 04-30-2012, 14:38   #3 (permalink)
Registered User
 
Join Date: Apr 2012
Posts: 2
Re: 2003 Ford Expedition Coils

Hi Bert,

I'm not sure what brand the 3-week old coil was...our mechanic did say that the new one is the same as what came on the vehicle so it does sound like the 3-week old coil was a different brand. He also changed out the spark plug, and that is Motorcraft. Hoping the problem is fixed!
ws1122 is offline   Reply With Quote
Old 04-30-2012, 15:21   #4 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,748
Re: 2003 Ford Expedition Coils

Thanks for the update.
__________________
Bert
Bert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.