2003 ford expedition remotes and kepad - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-16-09, 11:32 PM Thread Starter
Registered User
 
Join Date: May 2009
Posts: 1
2003 ford expedition remotes and kepad

Hello all.I have a problem i dont see on here at all.ok first of my remote stopped working yesterday both of them.then today the keypad stopped and wont light up.And not the auto locks and 3rd row power seats stopped and the rear back glass wont open.oh and also my auto lights stoped.im wondering if i have a short.i checked all fuses.(nothing).Also the code for the doors dont work.Keypad Not Lighting up )Anyone know what happined.Thanks

ssiburt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-18-09, 12:22 PM
canuck
 
360ci's Avatar
 
Join Date: Nov 2007
Location: Waterloo
Posts: 2,481
Re: 2003 ford expedition remotes and kepad

A short is a possibility, but I can't see one short affecting all those electrical systems. It seems to be a lot of amps to go through one circuit. Then again, it could be all relayed to a 40 amp fuse. I know you mentioned you checked fuses, but keep in mind there is most likely two fuse panels, one under the hood with the power relays, and one along the side, or under the dash for most of the 12V convenience items, etc. Electrical shorts can be HARD to find. If you have a good multimeter you should be able to oHm out the problem yourself.

'11 Ram Quad Cab 4x4 SXT 5.7L HEMI (stock); 48,500m
'06 Pontiac G6 GT 3.5L 220hp; 64,000m
'12 Chrysler 200 Limited 3.6L 283hp; 28,000m
'99 Taurus 3.0L 2V Vulcan 145hp; 154,300m - Traded
Amsoil in all vehicles!
360ci is offline  
post #3 of 4 (permalink) Old 05-18-09, 05:13 PM
Administrator
 
Join Date: Sep 2006
Location: Arkansas
Posts: 6,863
Re: 2003 ford expedition remotes and kepad

Quote:
BSM (door locks, liftgate glass release relay), Liftgate glass release motor, Door/Liftgate lock motors
Should be fuse #30. The fuse may look good but actually be blown.
jwko is offline  
post #4 of 4 (permalink) Old 07-26-09, 09:24 PM
Registered User
 
Join Date: Jan 2009
Posts: 3
Re: 2003 ford expedition remotes and kepad

Did you ever resolve this? I'm having some of the same problems, no power locks (unlock, lock, keypad, or remote), and the driver side window will not work. I can hear one of the relays clicking in the BSM when i try to lock/unlock but the motor never activates.

I checked fuse #30 (even swapped it with a working fuse) and no good. I'm thinking the whole BSM needs to be replaced.

One other strange thing I noticed, the map light and rail light on the drivers side are also not working. These are also on the same fuse as the vanity mirrors which were working. I decided to pull the fuse and reseat and now the map light is working and still no rail. Strange???? Makes me think there are some bad connections on the back side of the fuse terminals.
jaymd123 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome