2003 Ford Expedition stuttering in gear Help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Ford Expedition Forum | Lincoln Navigator Forum Forum for discussion of the Ford Expedition and Lincoln Navigator.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-21-2010, 20:46   #1 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 2
2003 Ford Expedition stuttering in gear Help!

Im new to this forum and posting in general so I apologise in advance if I sound dumb. I have a 2003 Expedition EB 4x4 5.4L. It rough idles / stutters when in gear at low idle and very low acceleration. In park runs fine at higher acceleration and speed runs fine. Just had all coil packs and plugs replaced. No codes at this time. Any help would be great I dont know where to start.
srmsparky is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-21-2010, 21:22   #2 (permalink)
2002 F150 XLT
 
Bert's Avatar
 
Join Date: Nov 2008
Location: Oregon
Posts: 9,809
Re: 2003 Ford Expedition stuttering in gear Help!

Try cleaning the MAF with MAF cleaner. Does the rough idle feel like an engine miss or just erratic rough running?
__________________
Bert
Bert is offline   Reply With Quote
Old 06-22-2010, 10:29   #3 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 4
Re: 2003 Ford Expedition stuttering in gear Help!

When was the last time your fuel filter was changed? That could be the problem especially if you don't have a CEL.
cmack is offline   Reply With Quote
Old 06-26-2010, 22:05   #4 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 4
Re: 2003 Ford Expedition stuttering in gear Help!

Check the COP boots (Coil on plug), for cracking near the open end, as well.
Warren1974 is offline   Reply With Quote
Old 07-19-2010, 09:49   #5 (permalink)
Registered User
 
Join Date: Jun 2010
Posts: 2
Re: 2003 Ford Expedition stuttering in gear Help!

Quote:
Originally Posted by rtg143 View Post
Try cleaning the MAF with MAF cleaner. Does the rough idle feel like an engine miss or just erratic rough running?
I will try cleaning the MAF sensor , it feels like a miss or hesitation. I notice it the most when sitting at a light or drive thru with foot on brake in gear idling and then when I start to accelerate when I get higher in speed seems to go away runs good. In park idles excellent , it misses / hesitates with or without OD .

Thanks for reply ( sorry for my delay in replying , I have been away from computer for a while)
srmsparky is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Trucks | Utes | Vans |SUVs | Crossovers > Ford Expedition Forum | Lincoln Navigator Forum



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 12:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.